Как работает функция ЕСЛИ в Excel: примеры использования

Выясняем назначение функции если в MS Ecxel и разбираемся в работе оператора с несколькими или одним условием.

Как работает функция ЕСЛИ в Excel: примеры использования

Как в Экселе использовать функцию ЕСЛИ

Приложение Excel, как и Word от Microsoft, является одной из самых полезных и функциональных программ для работы с документами. Она содержит множество опций, необходимых для любой сферы.

Функция ЕСЛИ описывает условие и результат, который получается при его выполнении или, наоборот, невыполнении. Это одна из базовых функций программы Excel, которую используют при создании отчетов: для бухгалтерии, списка товаров или имен, поиска ошибок в больших таблицах и так далее.  

Часто с помощью функции ЕСЛИ в Excel сравнивают содержимое ячеек с каким-то эталонным значением, чтобы поделить их на определенные категории.

Для примера мы создали таблицу с фамилиями и возрастом случайно выбранных людей. Предположим, что в третьем столбике напротив каждого человека надо проставить его «социальный статус» — ребенок это или взрослый. Это можно сделать с помощью функции ЕСЛИ.


Ставим курсор в ячейку напротив первого участника таблицы — у нас это D4. Вводим «=» и выбираем функцию ЕСЛИ в списке над таблицей.


Откроется новое окно, в котором надо задать параметры функции.


Логическое выражение — любое условие, при выполнении которого можно получить ответ «да» или «нет», что на языке Экселя обозначается как «ложь» и «истина». В нашем случае мы сравниваем возраст человека с числом 18, чтобы определить, взрослый это или ребенок. Значит, в поле «Лог_выражение» следует записать формулу «С4 (ячейка с возрастом) >=18». В графе «Значение_если_истина» пишем «Взрослый», а в «Значение_если_ложь» — «Ребенок». Все буквенные обозначения должны быть в кавычках.


Кликаем ОК или нажимаем Enter. В ячейке D4, куда вводилась формула, появится результат вычислений. Чтобы применить функцию к другим позициям в таблице, надо растянуть ее на другие ячейки с помощью автозаполнения (выделения с черным крестиком).


В логическом условии функции ЕСЛИ сравнивают не только числа. Например, можно проверить, есть ли в ячейке конкретное слово.

Создадим для этого еще одну функцию, которая будет обращаться к ячейке D4, в которой у нас уже есть результат работы первого оператора:


Новая функция проверяет, есть ли в ячейке слово «Взрослый». Если да — она возвращает значение 500, если нет — 200.


Изучаем Эксель: функция ЕСЛИ с несколькими условиями

Чаще для сортировки значений недостаточно сравнить их с помощью только одного выражения. Поэтому функцию ЕСЛИ можно использовать с несколькими условиями, вкладывая их в друг друга. Разберем на примере.

Предположим, надо поделить участников таблицы не на две категории, а на три — «Ребенок», «Взрослый» и «Пожилой.» Для этого уже недостаточно простой проверки «больше или равно 18» — а значит, надо ввести еще одно условие: в нашем случае это будет «больше 60».

Синтаксис функции ЕСЛИ выгляд&#...
Синтаксис функции ЕСЛИ выглядит следующим образом: =ЕСЛИ(логическое_выражение;значение_если_истина;значение_если_ложь) Аргументы после оператора ЕСЛИ заключены в скобки и разделены точкой с запятой. Добавляя новые условия, важно сохранить такой же порядок.

В первом примере наша формула выглядела так: ЕСЛИ(C4>=18;"Взрослый";"Ребенок")

Добавим в ней еще одно выражение - C4>60. Также надо прописать “Значение_если_истина”, которое будет выдавать Excel при соответствии - “Пожилой”. В поле “Значение_если_ложь” оставим формулу из первого примера и добавим в конце еще одну закрывающую скобку. В итоге получится: =ЕСЛИ(C4>60;«Пожилой»;ЕСЛИ(C4>=18;«Взрослый»;«Ребенок»))


Для чистоты эксперимента добавим пару новых строк, чтобы в столбце были значения для каждого возраста. Растягивает формулу и видим результат — два последних человека распознаны как пожилые.


В MS Excel 2010 таким образом можно вкладывать друг в друга до семи условий.

Читайте также:

Подпишись на канал IVD в Яндекс.Дзен